Al-Matsurat Domain Issues
Incident Report for imuslim
Resolved
This Incident Has Been Resolved
Posted Apr 10, 2022 - 06:54 WIB
Investigating
We are sorry that, currently our al mathsurat domain is currently down, we are still investigating how this issue occur.
Posted Apr 09, 2022 - 21:44 WIB
This incident affected: [SGP1] Al-Matsurat Server and DNS Networking.